
Map Scanning and Automated Conversion Exercises 
 
Practical Exercise with R2V Evaluation Software (ACT) 
 
The following hands-on exercises will explain step by step automated and semi-
automated conversion process. 

Down load the demonstration version of R2V software before carrying out the 
exercises from Able R2V software. (http: //www.ablesw.com/r2v/) 

 

1. Conversion of line (contour) from 1 bit bi-level image 
 

1. Run R2V Demo Version. Start > Programs > Able Software R2V > R2VDemo. 
 
2. Select the file name TOPO.TIF when the file selection window prompts.  
 
3. Click OK when the warning window of evaluation version appears. 
 
4. The scanned image of contour lines appears. Check the image that includes 
raster lines representing contour lines, cross points representing peaks and text 
representing the value of contour line and elevation. Major contours have thicker 
line. The contour interval is 20 meter. Although, all the contour lines are not 
labelled, the values of contours can be extract from the values of peak points. 
 
5. See the information of image by using main menu: Image > Information. The 
image attribute window will appear. Check the columns, rows, bits per pixel, 
number of layer or plane, type of image, scanning resolution and resolution unit. 
This image is monochrome image or 1 bit BI-level image. That’s mean it is 0,1 
image. All the pixel values are 0 or 1. Press OK after checking the Image 
Attributes. 
 
6. Zoom In the image by pressing F2 or clicking Zoom In Lens Icon in the tool bar 
or by selecting View > Zoom In from main menu. Zoom In the image until you are 
comfortable to see the raster lines. Another way to Zoom In the desired are is as 
follow. Select the Select Mode Arrow Icon. Draw a box around the desired area. 
Then click F2. 
 
7. To check the pixel values, go to the main menu: Image > Image Pixel Tool > 
Image Pixel Tool On/Off. The Image Pixel Tool On/Off should be checked. The 
Show Pixel Value should be checked. If it has already been check, click 
somewhere on the screen to escape the menu.  
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8. Click on the raster contour line. The value will display at the lower right corner 
of the screen. The values of raster line of contours are 0. 
 
9. Click on the screen, outside of raster lines. The value will display at the lower 
right corner of the screen. The values of non-raster lines of contours are 1.  
 
10. Then Zoom Out the image by pressing F3 or clicking Zoom Out Lens Icon in 
the tool bar or by selecting View > Zoom Out from main menu.  
 
11. From this Image, the contour vector lines and peak points will be extracted to 
two different layers called contour and peak. In order to do so, layers have to be 
created. Select Edit > Layer Define or click Define Layer Icon in the Tool Bar. 
Tool tips display when the mouse moves over the icon, in order to identify the 
icon.  
 
12. The layer management window appears. Click inside the text box below the 
layer management window. Then type “contour”. It is the layer name to store 
the contour line vectors. Then click Add Layer Button. The contour layer name 
appears in the larger text box.  
 
The lower textbox will be empty.  
 
Again, click inside the text box below the layer management window. Then type 
“Peak”. It is the layer name to store the peak points vectors. Then click Add 
Layer Button. The peak layer name appears in the larger text box.  
 
Accept the default color and line type.  
 
Firstly, contour will be focused to convert to vectors. Therefore contour layer will 
be set as ON and Current. Other layers will be set to OFF. In order to do so, click 
on the layer 0 to highlight and select it. Then click On/Off button. Its flag should 
be OFF. Then click on the layer peak to highlight and select it. Then click On/Off 
button. Its flag should be OFF. Then click on the layer contour to highlight and 
select it. Then click Current button. Its flag should be On Current (On C.).  
 
Then press OK. So, presently, contour layer is only ON and Current. The result 
of conversion will be stored in the contour layer.  
 
13. As the image is 0,1 image and the information to be extracted are 
represented as 0 value and the information to be excluded are represented as 1. 
Therefore, automated conversion can be directly operated.  
 
Select Vector > Auto Vectorize from main menu or click Auto Vectorize Icon from 
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tool bar. Vectorize Window appears. Select the Image Source as MAP in the list 
box. Select the Center Line Option Radio Button. Then click Start Button to 
vectorize.  
 
14. The contour vector line appears. The result should be saved before 
correcting the errors. Therefore, go to File > Layer > Save layer. Give the file 
name as contour or any name of your choice. Moreover, the file should be export 
to Line File (*.gen) format. Go to File > Export Vector. Save as Window appears. 
Select the file type as Line File (*.gen), and provide the name as contour. The file 
name will be contour.gen.  
 
15. In the immediate result,  
 
- Some contours are not connected.  
 
- Some contours are mistakenly connected.  
 
- The texts are also vectorized. The vectorized text must be removed.  
 
- The crosses that represent the peaks are not contours. Therefore, the crosses 
must be removed.  
 
16. The crosses will be removed first. In order to do so, Zoom In the 662 Peak 
area where a cross (a peak) appears. Use select mode arrow; draw box and F2 
Key to Zoom In desire area.  
 
17. Click Line Editor Icon (the first icon on the toolbar of second row) from the 
tool bar or Edit > Line Editor > Line Editor On/Off from main menu.  
 
18. Then click the Show Line Nodes Icon and Show Line Ends Icon. You can 
identify these icons by moving mouse over the icons and check the tool tips. 
After clicking the Show Line Nodes Icon and Show Line Ends Icon, the nodes 
and ends of the line appear.  
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The line is identified by the Line Ends. Line A is part of cross and well defined by 
Line ENDS. Line A is easy to delete.  
 
However, Line B is part of cross and at the same time part of contour line. To 
delete the undesirable portion of Line B, it is necessary to split. Then delete the 
portion of cross and connect the line to form the contour.  
 
19. To delete the Line A, click Line Editor Icon. The other editing tools are also 
active and enabled. The click on Delete Line Icon. Then click on Line A. Line A 
will be deleted.  
 
20. To split the Line B, select Split Line Icon. Then click on the line B where to be 
split. The Line End will appear. Then select the Delete Line Icon and click on the 
undesirable portion of Line B to delete it.  
 
21. Two connect the gap on Line B, select the Join Line Icon, then click on a Line 
End, without releasing the mouse, move onto another Line End and release the 
mouse. The Line B is connected and representing the contour vector. Join line is 
useful to connect the very small gap. Save the layer again using File > Layer > 
Save Layer. File name should be the same “contour”.  
 
22. Then correct the other geometry errors. The available editing tools for vector 
geometry is Add Node, Remove Node, Move Node, Snap to Node, Split Line, 
Join Line, Close Line, Copy Line, Move Line and Delete Line. Read about these 
commands in the R2V Help before proceeding especially how to use and press 
with the mouse to use the function of Icons.  
 
23. If the gap is very large, to digitize the gap, the Auto Tracing should not be 
checked in order to avoid errors in tracing. Therefore, to digitize the large gap, 
after clicking line Editor icon, right click on the screen and uncheck Auto Tracing 
if necessary. It is recommended to set the snap distance in order to snap the line 

Scanning Exercises  - 4 - 18.02.2003 



node to line end. While Line Editor is active, right click on the screen and select 
snap distance. Then enter the appropriate value to snap between line end and 
line node if the gap is smaller than the snap distance. Click on Draw/Trace Line 
Icon to digitize the gap. Snap to Node Icon also should be active while digitizing. 
You can press S to snap to the other Line End.  
 
24. After correction of geometry of errors, the layer should be saved. The layer 
name is “contour”.  
 
25. The file can be exported to GIS at this stage in order to add attributes. To 
export the file click Export Vector Icon or select File > Export vector from menu. 
Select output file type as ArcView Shape File (. shp) and file name as 
“ContourGeomshape”. This file can be read into ArcMap and edit the attributes 
as we have learnt in Digitizing Section and Editing prima Section.  
 
26. Moreover, the file should be export to Line File (*.gen) format. Go to File > 
Export Vector. Save as Window appears. Select the file type as Line File (*.gen), 
and provide the name as contourGeomgen. The file name will be 
contourGeomgen.gen.  
 
27. Alternatively, the file can be added attributes values such as contour values 
as ID in R2V. In order to do so, the ID of major contours will be assigned first.  
 
28. 600 Contour line will be assigned first. Click Set Value Icon first. Current ID 
Value window will appears. In the Type ID As: Text box, type 600. Increase ID 
Every Time By: check box and text box will not be checked because we will not 
use the auto increase ID. Then press OK.  
 
29. The mouse cursor changes to Vertical Arrow with a word ID. Then point to 
600 Contour line. The contour line color change. That means, the highlighted 
colored portion of line is assigned as ID 600. While entering the ID values, the 
geometry error may encounter. Correct the geometry error, then assign the ID.  
 
30. Then assigned the other contour ID according to their contour value.  
 
31. While adding the ID values, the layer should be frequently saved.  
 
32. After adding the ID values, the layer should be exported to two vector 
formats, shape file format (.shp) and Line File (*.gen) format.  
 
33. To export the file click Export Vector Icon or select File > Export vector from 
menu. Select output file type as ArcView Shape File (. shp) and file name as 
“ContourIDshape”. This file can be read into ArcInfo, ArcMap and ArcView.  
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34. Moreover, the file should be export to Line File (*.gen) format. Go to File > 
Export Vector. Save as Window appears. Select the file type as Line File (*.gen), 
and provide the name as contourIDgen.  

 

2. Conversion of polygon (parcel) from 1 Bit Bi-level Image 
 

1. Run R2V Demo Version. Start > Programs > Able Software R2V > R2VDemo.  
 
2. Select the file name VIEWMAP.TIF when the file selection window prompts.  
 
3. Click OK when the warning window of evaluation version appears.  
 
4. The scanned image of parcels appears. Check the image that includes raster 
lines representing parcel boundaries and text.  
 
5. See the information of image by using main menu: Image > Information. The 
image attribute window will appear. Check the columns, rows, bits per pixel, 
number of layer or plane, type of image, scanning resolution and resolution unit. 
This image is monochrome image or 1 bit BI-level image. That’s mean it is 0,1 
image. All the pixel values are 0 or 1. Press OK after checking the Image 
Attributes.  
 
6. Zoom In the image by pressing F2 or clicking Zoom In Lens Icon in the tool bar 
or by selecting View > Zoom In from main menu. Zoom In the image until you are 
comfortable to see the raster lines. Another way to Zoom In the desired are is as 
follow. Select the Select Mode Arrow Icon. Draw a box around the desired area. 
Then click F2.  
 
7. To check the pixel values, go to the main menu: Image > Image Pixel Tool > 
Image Pixel Tool On/Off. The Image Pixel Tool On/Off should be checked. The 
Show Pixel Value should be checked. If it has already been check, click 
somewhere on the screen to escape the menu.  
 
8. Click on the raster contour line. The value will display at the lower right corner 
of the screen. The values of raster line of parcel boundaries are 0.  
 
9. Click on the screen, outside of raster lines. The value will display at the lower 
right corner of the screen. The values of non-raster lines of contours are 1.  
 
10. Then Zoom Out the image by pressing F3 or clicking Zoom Out Lens Icon in 
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the tool bar or by selecting View > Zoom Out from main menu.  
 
11. From this Image, the parcel boundary vector lines will be extracted to parcel 
layer. In order to do so, layer has to be created. Select Edit > Layer Define or 
click Define Layer Icon in the Tool Bar. Tool tips display when the mouse moves 
over the icon, in order to identify the icon.  
 
12. The layer management window appears. Click inside the text box below the 
layer management window. Then type parcel. It is the layer name to store the 
parcel boundary line vectors. Then click Add Layer Button. The contour layer 
name appears in the larger text box.  
 
Accept the default color and line type.  
 
Firstly, parcel boundary will be focused to convert to vectors. Therefore parcel 
layer will be set as ON and Current. Other layers will be set to OFF. In order to 
do so, click on the layer 0 to highlight and select it. Then click On/Off button. Its 
flag should be OFF. Then click on the layer parcel to highlight and select it. Then 
click Current button. Its flag should be On Current (On C).  
 
Then press OK. So, presently, parcel layer is only ON and Current. The result of 
conversion will be stored in the contour layer.  
 
13. As the image is 0,1 image and the information to be extracted are 
represented as 0 value and the information to be excluded are represented as 1. 
Therefore, automated conversion can be directly operated.  
 
Select Vector > Auto Vectorize from main menu or click Auto Vectorize Icon from 
tool bar. Vectorize Window appears. Select the Image Source as MAP in the list 
box. Select the Center Line Option Radio Button. Then click Start Button to 
vectorize.  
 
14. The contour vector line appears. The result should be saved before 
correcting the errors. Therefore, go to File > Layer > Save layer. Give the file 
name as parcel or any name of your choice. Moreover, the file should be export 
to Line File (*.gen) format. Go to File > Export Vector. Save as Window appears. 
Select the file type as Line File (*.gen), and provide the name as parcel. The 
Vertical Flip option radio button should be selected. Then press OK. The file 
name will be parcel.gen.  
 
15. In the immediate result, - Some lines are not connected. 
 
- Some lines are not part of the polygons. Let’s call it orphan lines. 
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- The texts are also vectorized. The vectorized text must be removed.  
 
16. The text will be removed first. In order to do so, Zoom in the text area at the 
top. Use select mode arrow, draw box and F2 Key to Zoom In desire area.  
 
17. Click Line Editor Icon (the first icon on the toolbar of second row) from the 
tool bar or Edit > Line Editor > Line Editor On/Off from main menu.  
 
18. Then click the Show Line Nodes Icon and Show Line Ends Icon. You can 
identify these icons by moving mouse over the icons and check the tool tips. 
After clicking the Show Line Nodes Icon and Show Line Ends Icon, the nodes 
and ends of the line appear. The line is identified by the Line Ends. If the line 
nodes are disturbing to your view, turn off Show Lines Nodes.  
 
19. Then correct the following geometry errors. The available editing tools for 
vector geometry is Add Node, Remove Node, Move Node, Snap to Node, Split 
Line, Join Line, Close Line, Copy Line, Move Line, Delete by Line length, Delete 
by Line ID, Delete by Line Type and Delete Line. Read about these commands in 
the R2V Help before proceeding especially how to use and press with the mouse 
to use the function of Icons. Use the experience of editing in Scanning Exercise I.  
 
20. To delete the Lines that represent the text, click Line Editor Icon. The other 
editing tools are also active and enabled. The click on Delete Line Icon. Then 
click on Lines that represent the text.  
 
21. Delete the short overshoot dangle.  
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To delete the overshoot dangle line Use Vector > Delete Line by Length to delete 
by a threshold length or Use Delete Line Icon to delete the short dangle lines 
individually. In this exercise, use Vector > Delete Line by Length.  
 
Zoom in particular area where overshoot short dangles and line ends, which are 
very near to another ends.  
 
Then, select Vector > Delete Line by Length. Removing Line window appears. 
Test the threshold maximum value starting from 1. 
 
Change the maximum threshold to 1 and click Apply. Check the overshoot 
dangles are cleared or not. At the same time, check unnecessary delete of line 
and forming gap of polygons, occurred or not. Maximum Threshold Value 1(pixel) 
does not delete the short dangle in this exercise data. Therefore press Cancel.  
 
Then increase threshold maximum value to 2. Check the results and errors as 
before. The following figures show the connectivity before applying the threshold 
value 2. 
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The following figure shows the connectivity after applying threshold value 2. 
 

 
 
The small arc is unnecessarily deleted. Therefore, in the case of our exercise, 
the maximum threshold value should be less than 2 in order to keep the 
polygons.  
 
Now realizing that we should select the threshold value to 1.5 and delete 
manually remaining short overshoot dangle using Delete Line. In order to do so 
set threshold maximum value to 1.5. Then press Apply. Then accept the result by 
pressing OK.  
 
Most of the dangle overshoot lines remained. Delete these remaining lines by 
using Line Editor > Delete Line.  
 
Moreover, the small polygons as shown below should be corrected by deleting 
unnecessary arc. These small polygons are formed due to the error on the 
original document or scanning resolution. 
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An arc was deleted as follow to include the small false polygon into the bigger 
true polygon. 
 

 
 
21. Split the line if the ends are not detected to join and to form the polygons. 
The following figure shows the case, an arc or line need to be split. It is not 
necessary to join the line at the intersection. However, these should be close 
enough to the tolerance for the Create Polygon Layer process, which will be 
discussed next paragraph. The large gap should also be closed by Move Node. 
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22. Click the Select Mode arrow. Then select Vector > Create Polygon Layer in 
order to create polygons. Create Closed Polygon Window will appear. The value 
for maximum gap tolerance would be equivalent to 1 pixel or 2 pixels. In this 
exercise, value 1 will be used. Make sure to “Check the split intersection check 
box” in order to create the node at the intersection. Then click Apply. If the result 
is unsatisfactory, click the Cancel and change the tolerance and Apply again. In 
this exercise, we will accept the result. So click OK.  
 
23. The errors such as unclosed polygons, undershoot dangles, overshoot 
dangles and small polygons should be check again. Correct if necessary using 
Vector Editing Tools. Bird Eye View and moving Zoom window in the Bird Eye 
View is useful to check and visualize the errors.  
 
24. After correction of geometry of errors, the layer should be saved. The layer 
name is “parcel”.  
 
25. The file can be exported to GIS at this stage in order to add attributes. To 
export the file click Export Vector Icon or select File > Export vector from menu. 
Select output file type as ArcView Shape File (. shp) and file name as 
“ParcelGeomshape”. Make sure to check the Check Box for Use Polygon For 
Close Lines. This file can be read into ArcMap and edit the attributes as we have 
learnt in Digitizing Section and Editing prima Section.  
 
26. Moreover, the file should be export to Line File (*.gen) format. Go to File > 
Export Vector. Save as Window appears. Select the file type as Line File (*.gen), 
and provide the name as ParcelGeomgen. The file name will be 
ParcelGeomgen.gen. The ArcInfo Generate Format file can be imported to any 
GIS package for attribute edition. In this exercise, the attribute values are not 
provided. The R2V provide the assigning ID values for lines and points. However, 
it does not provide assigning ID to polygons. Therefore, it is better to add the 
attribute values of polygons in the GIS environment.  
 
27. Challenge if you are using ArcGIS in your lab: Import the 
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ParcelGeomgen.gen using ArcToolBox. Create a geodatabase in ArcCatalog and 
add the Parcel Vector Data that you have imported. Display it in the ArcMap.  
 
 

3. Conversion of Polygon (Parcel) from Color Image 
 

1. Run R2V Demo Version. Start > Programs > Able Software R2V > R2VDemo.  
 
2. Select the file name SPOT.TIF when the file selection window prompts.  
 
3. Click OK when the warning window of evaluation version appears.  
 
4. The scanned image of land use appears. Check the image that includes yellow 
raster lines representing road and raster polygons representing by different 
colors.  
 
5. See the information of image by using main menu: Image > Information. The 
image attribute window will appear. Check the columns, rows, bits per pixel, 
number of layer or plane, type of image, scanning resolution and resolution unit. 
This image is 8-bit palette image. That means all the pixel values ranging from 0 
to 255. Press OK after checking the Image Attributes.  
 
6. From this Image, the vector lines that represent polygon boundaries will be 
extracted to LULINE and LUPOLY layers. In order to do so, LULINE and 
LUPOLY layers have to be created. Select Edit > Layer Define or click Define 
Layer Icon in the Tool Bar.  
 
7. The layer management window appears. Click inside the text box below the 
layer management window. Then type LULINE. It is the layer name to store the 
land use line vectors. Then click Add Layer Button. The LULINE layer name 
appears in the larger text box.  
 
The lower textbox will be empty.  
 
Again, click inside the text box below the layer management window. Then type 
LUPOLY. It is the layer name to store the land use polygon vectors. Then click 
Add Layer Button. The LUPOLY layer name appears in the larger text box.  
 
Accept the default color and line type.  
 
Firstly, land use boundary line will be focused to convert to vectors. Therefore 
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LULINE layer will be set as ON and Current. Other layers will be set to OFF. In 
order to do so, click on the layer 0 to highlight and select it. Then click On/Off 
button. Its flag should be OFF. Then click on the layer LUPOLY to highlight and 
select it. Then click On/Off button. Its flag should be OFF. Then click on the layer 
LULINE to highlight and select it. Then click Current button. Its flag should be On 
Current (On C.).  
 
Then press OK. So, presently, LULINE layer is only ON and Current. The result 
of conversion will be stored in the LULINE layer.  
 
8. Select Vector > Auto Vectorize from main menu or click Auto Vectorize Icon 
from tool bar. Vectorize Window appears. Select the Image Source as MAP in 
the list box. Select the Boundary Line Option Radio Button. Then click Start 
Button to vectorize.  
 
9. The vector lines that represent polygon boundary and road appear. The result 
should be saved before correcting the errors. Therefore, go to File > Layer > 
Save layer. Give the file name as LULINE or any name of your choice. Moreover, 
the file should be export to Line File (*.gen) format. Go to File > Export Vector. 
Save as Window appears. Select the file type as Line File (*.gen), and provide 
the name as LULINE. The file name will be LULINE.gen.  
 
10. The ArcMap Geometry and Attribute Editing capability is superior to R2V 
especially in Geodatabase data model. R2V is superior to ArcMap in automatic 
and semi automatic vector conversion from image of various formats. To take the 
advantage of both systems, in real world project LULINE.GEN would be import to 
ArcGIS using ArcToolBox as vector line data. Then it would be imported to 
Geodatabase through ArcCatalog. Then the geometry and attribute will be edited 
in ArcMap to create the polygon geometry and attributes for the GIS database. 
As you are already familiar with ArcMap, ArcCatalog and ArcToolBox, the step 
10 would be challenge exercise.  
 
11. In order to get the experience on R2V, the water polygons (dark blue) will be 
extracted from the vector line data.  
 
12. In the immediate result from Step-9, observe the following.  
 
- Most of the polygons are not closed.  
 
- An inherent characteristic of raster to vector conversion is stair steps and 
smooth vector line.  
 
- The raster line (yellow color) also converted as vector line. It should be saved to 
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different line layer because it is not the polygon.  
 
- Shape of geometry is not exactly the same to the original raster polygon.  
 
13. Click Line Editor Icon (the first icon on the toolbar of second row) from the 
tool bar or Edit > Line Editor > Line Editor On/Off from main menu.  
 
14. Then click the Show Line Nodes Icon and Show Line Ends Icon. You can 
identify these icons by moving mouse over the icons and check the tool tips. 
After clicking the Show Line Nodes Icon and Show Line Ends Icon, the nodes 
and ends of the line appear. Off the Show Line Nodes in order to view the line 
ends only.  
 
15. In this exercise, we are interested in water polygons, which are represented 
dark blue color. Therefore, single lines that represent the water will be deleted 
because it represents streams. Zoom in the line if necessary. To delete the 
unwanted single lines, click Line Editor Icon. The other editing tools are also 
active and enabled. The click on Delete Line Icon. Then click on the line, which 
are to be deleted.  
 
16. In order to save the water vector polygon data, the LUPOLY layer should be 
ON CURRENT and LOCK (ON.C.L) while LULINE is ON. Click Define Layer 
icon, and then use Layer Management Window in order to set. Note that, it is 
necessary to highlight the layer before setting. After setting, click OK.  
 
17. Start with simplest water polygon. Zoom In to a comfortable level.  
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In the above figure, some single lines that represent water have deleted. The 
small water polygon (south most) in above figure will be converted and save into 
LUPOLY. Click Form Polygon Icon in the tool bar. Select lines, which will be used 
as the new polygon boundary with the left mouse button. Selected lines are 
displayed with inverted color. To deselect the last line, simply press the 
BACKSPACE (<-) key or the ESC key. When all lines are selected, press Enter 
key to form the closed polygon. The newly created polygon is put in the current 
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layer (LUPOLY) and the existing line segments stay unchanged. Add the another 
water polygon, on the west of present one similarly.  
 
The bigger water polygon shape will be modified in order to resemble raster 
polygon shape. In order to do so, the LUPOLY layer should be OFF. Set the 
LULINE layer ON and CURRENT. Then change the shape of the polygon 
geometry using vector editing tool that have already learnt. After changing the 
shape, set the LULINE to ON and LUPOLY to ON, CURRENT and LOCK. Click 
Form Polygon Icon in the tool bar. Select lines, which will be used as the new 
polygon boundary with the left mouse button. Selected lines are displayed with 
inverted color. To deselect the last line, simply press the BACKSPACE (<-) key 
or the ESC key. When all lines are selected, press Enter key to form the closed 
polygon. The newly created polygon is put in the current layer (LUPOLY) and the 
existing line segments stay unchanged.  
 
If mistake occurred after forming the polygon, follow the following steps. Set 
LULINE to OFF. Set LUPOLY to ON CURRENT. Then delete the mistaken 
polygon. Then Set the LUPOLY ON CURRENT and LOCK and LULINE to ON. 
Then select the Form Polygon icon and follow the same procedure to capture the 
polygon in LUPOLY again.  
 
Add the other polygon similar way. Some water polygon (top right) will be needed 
to digitize to complete the boundary in order to close the polygon. In such as 
case, digitize the missing line in LULINE. It is important to set CURRENT ON 
mode to LULINE and OFF mode to LUPOLY. After adding boundary to close the 
polygon in LULINE, set ON to LULINE. Then set CURRENT, ON and LOCK to 
LUPOLY. Then use Form Polygon to add the polygon to LUPOLY.  
 
18. After converting water polygons, the layer should be saved. The layer name 
is “LUPOLY”.  
 
19. The file should be export to Line File (*.gen) format. Go to File > Export 
Vector. Save as Window appears. Select the file type as Line File (*.gen), and 
provide the name as Waterpoly. The file name will be waterpoly.gen. 
 
20. As the challenge exercise, import the waterpoly.gen to ArcMap and add the 
attribute value for water polygon. The id for water polygon is 99.  
 
21. Challenge: convert all the land uses, which are represented by Yellow, 
Green, Light Brown, Light Blue and Dark Green. Remove single lines, which are 
represented by string of single pixels.  
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4. Image Georeferencing and Editing Vector 
 

1. Run R2V Demo Version. Start > Programs > Able Software R2V > R2VDemo.  
 
2. Select the file name Fribourg200.jpg when the file selection window prompts. 
Originally, this image is scanned at 200 dpi from 1:10000 scale map, 8 bit gray 
scale and saved as tiff format. (.tif)  
 
3. Click OK when the warning window of evaluation version appears.  
 
4. The scanned gray scale image of small part of Fribourg appears. Check the 
image that includes raster lines representing roads, bridge, and raster polygons 
representing forests, buildings, and raster point symbols representing viewpoint 
and text representing the name of features.  
 
5. See the information of image by using main menu: Image > Information. The 
image attribute window will appear. Check the columns, rows, bits per pixel, 
number of layer or plane, type of image, scanning resolution and resolution unit. 
In order to convert the image to gray scale image, select Image > conversion and 
select 24 bit Gray scale. Then check the Image Information. It should be 
converted to 8 bit gray scale because maximum pixel value is 255.  
 
6. The grid is included in the image. The coordinate value of lower left grid corner 
is 795670, 179715 and upper right grid corner is 796170 and 180215. First, the 
image will be georeferenced.  

 

 

7. Zoom in the lower left corner. Click the Control Point Editor icon. Then click on 
the lower left corner of the grid carefully. Control point window appears. The x, y 
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values of FROM Frame is pixel coordinate. The x, y values of TO Frame is to put 
the ground coordinate. Type 795670 in the text box for X value in TO Frame. 
Type 179715 in the text box for Y value in TO Frame. Then press OK.  
 
8. Zoom out to the full extent and Zoom In the upper left corner. Click the Control 
Point Editor icon, if necessary. Then click on the upper left corner of the grid 
carefully. Control point window appears. The x, y values of FROM Frame is pixel 
coordinate. The x, y values of TO Frame is to put the ground coordinate. Type 
795670 in the text box for X value in TO Frame. Type 180215 in the text box for 
Y value in TO Frame. Then press OK.  
 
9. Zoom out to the full extent and Zoom In the upper right corner. Click the 
Control Point Editor icon, if necessary. Then click on the upper right corner of the 
grid carefully. Control point window appears. The x, y values of FROM Frame is 
pixel coordinate. The x, y values of TO Frame is to put the ground coordinate. 
Type 796170 in the text box for X value in TO Frame. Type 180215 in the text 
box for Y value in TO Frame. Then press OK.  
 
10. Zoom out to the full extent and Zoom In the lower right corner. Click the 
Control Point Editor icon, if necessary. Then click on the lower right corner of the 
grid carefully. Control point window appears. The x, y values of FROM Frame is 
pixel coordinate. The x, y values of TO Frame is to put the ground coordinate. 
Type 796170 in the text box for X value in TO Frame. Type 179715 in the text 
box for Y value in TO Frame. Then press OK.  
 
11. The control points should be saved. Therefore, select File > Save Control 
Point. Give the name as Fribourg200CP or any name as you wish.  
 
12. Then select the view and check Geo-coded Coordinates. So, if you move 
your mouse, the geographic coordinate will display at the lower right corner of the 
screen.  
 
13. In this exercise, some road will be converted to road layer by semi 
automation.  
 
14. Therefore, first thing first. Some road will be converted to road layer. In order 
to do so, add the new layer using Define Layer icon and set to CURRENT ON.  
 
15. The main road Beau-Chemin will be converted. Check the pixel values that 
represent Beau-Chemin randomly. In order to do so, zoom in some portion of 
Beau-Chemin. Then select Image > Image Pixel Tool and check the Image Pixel 
Tool On/Off and Show Pixel Value. Then randomly click on the Beau-Chemin 
and take notes of values. It may be approximately 130 to 185.  
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16. Then select Image > Set Image Threshold. Sets Image Threshold window 
appears. Play the horizontal tool bars to set the lower value and higher value. Set 
the tool bar the best represent the Beau-Chemin and less significant 
representation of the other. In an experiment, minimum zero and maximum 176 
represent Beau-Chemin significantly. Press OK after setting thresholds.  
 
17. Then click Line Editor Icon. Then right click on the screen. New line and Auto 
Tracing should already be checked.  
 
18. Click at the start point of your choice. Then guide the tracing operation by 
clicking. If auto tracing trace to wrong direction, click backspace to delete and 
guide the way to trace. At the end, clicks enter or right click and select DONE. 
Other roads can be traced semi automatically similar way.  
 
19. In the R2V Demo version, the layer can not be exported for this data set. In 
full version, the layer can be exported to GIS and additional geometry edition if 
necessary, and other attribute editing can be carried out. During export vector 
process, the option to use Geo-coded Control Point will be available in order to 
export georeferenced vector data.  

 

5. Conversion of Polygon from the Grayscale Image 
 

1. Follow the step 1 to 5 of Scanning Exercise IV.  
 
2. The image has been already georeferenced in Scanning Exercise IV and 
control point file has been saved. Therefore, in order to load the control point file, 
select File > Load Control Points and navigate to Fribourg200CP.cpt.  
 
3. In this exercise, building footprints will be converted semi automation.  
 
4. Secondly, some buildings will be converted semi-automatically. Therefore add 
the BUILDLINE layer and BUILDPOLY layer. Set the BUILDLINE to CURRENT 
ON and BUILDPOLY to OFF. Therefore, all the result will be saved to 
BUILDLINE.  
 
5. If you Zoom In the some building foot print, it is not very smooth. In order to 
smooth it, select Image > Smooth > Average Filter. The image looks smoother.  
 
6. Then run the Vector > Auto Vectorize. Vectorize Window appears. Select the 
Image Source as MAP in the list box. Select the Boundary Line Option Radio 
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Button. Then click Start Button to vectorize. Not only building footprints but also 
other features are converted to line vectors. These vector lines are saved in 
BUILDLINE layer.  
 
7. Focus on Building Footprints. Zoom In each footprint. Correct the vector 
geometry if necessary in order to be able to form the polygon.  
 
8. After correcting the errors, set the BUILDPOLY ON CURRENT LOCK and set 
the BUILDLINE layer ON. Then click Line Editor Icon. Then click Form Polygon 
Icon in the tool bar. Select lines, which will be used as the new footprint polygon 
boundary with the left mouse button. Selected lines are displayed with inverted 
color. To deselect the last line, simply press the BACKSPACE (<-) key or the 
ESC key. When all lines are selected, press Enter key to form the closed 
polygon. The newly created polygon is put in the current layer (BUILDPOLY) and 
the existing line segments stay unchanged. Add the another footprint polygon 
similarly.  
 
If mistake occurred after forming the polygon, follow the following steps. Set 
BUILDLINE to OFF. Set BUILDPOLY to ON CURRENT. Then delete the 
mistaken polygon if necessary. Then Set the BUILDPOLY ON CURRENT and 
LOCK and BUILDLINE to ON. Then select the Form Polygon icon and follow the 
same procedure to capture the polygon in BUILDPOLY again. 
 
If mistake occurred before forming the polygon, follow the following steps. Set 
BUILDPOLY to OFF. Set BUILDLINE to ON CURRENT. Then correct the 
geometry to form polygon if necessary. Then Set the BUILDPOLY ON 
CURRENT and LOCK and BUILDLINE to ON. Then select the Form Polygon 
icon and follow the same procedure to capture the polygon in BUILDPOLY again.  
 
9. In the R2V Demo version, the layer can not be exported for this data set. In full 
version, the layer can be exported to GIS and additional geometry edition if 
necessary, and other attribute editing to be carried out. During export vector 
process, the option to use Geo-coded Control Point will be available in order to 
export georeferenced vector data.  
 
10. After adding the footprint polygons, set BUILPOLY to OFF. Add the new layer 
FORESTLINE and FORESTPOLY. Set the FORESTLINE to CURRENT ON. 
Other layers should be off.  
 
11. The forest polygons in the map have patterns. To digitize the forest polygons, 
follow the steps.  
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12. Click on Line Edit icon. Right click on screen. The New Line should be check. 
The Auto Trace Option should be off check. Then digitize each forest polygon 
manually. Press S to snap to the end point, C to close the polygon and T to auto 
trace. If necessary, reduce the value of Snap distance in order to avoid 
unnecessary snap to the other line nodes or line ends.  
 
13. After adding the line geometry to FORESTLINE, set the FORESTPOILY ON 
CURRENT LOCK and FORESTLINE ON.  
 
Then click Line Editor Icon. Then click Form Polygon Icon in the tool bar. Select 
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lines, which will be used as the new footprint polygon boundary with the left 
mouse button. Selected lines are displayed with inverted color. To deselect the 
last line, simply press the BACKSPACE (<-) key or the ESC key. When all lines 
are selected, press Enter key to form the closed polygon. The newly created 
polygon is put in the current layer (FORESTPOLY) and the existing line 
segments stay unchanged. Add the another forest polygon similarly.  
 
14. Then add the new layer call BFPOLY in order to keep both forest and 
building footprint polygon together. Then SET FORESTPOLY ON, BUILDPOLY 
ON and BFPOLY CURRENT ON.  
 
15. Then click Layer Manipulate Icon. Layer manipulate Window appears. Select 
the BUILDPOLY and FORESTPOLY in the FROM Frame. Select the BFPOLY in 
the TO Frame. Select the Copy Radio Option. Then press OK. The polygons 
from FORESTPOLY and BUILDPOLY copy to BFPOLY.  
 
16. Then OFF the other layer except BFPOLY. Change the line type and color, 
as you like. Then press OK. The forest and parcel polygons will display together.  
 
17. Although, in this DEMO version, the layer can not be exported. However, the 
export facility will be available in full version. In full version, the layer can be 
exported to GIS and additional geometry edition if necessary, and other attribute 
editing can be carried out. During export vector process, the option to use Geo-
coded Control Point will be available in order to export georeferenced vector 
data.  
 
18. In full version of R2V, the file should be export to Line File (*.gen) format. Go 
to File > Export Vector. Save as Window appears. Select the file type as Line File 
(*.gen), and provide the name Landusegen. The file name will be 
Landusegen.gen. This file can be imported to ArcGIS using ArcToolBox, 
Imported to geodatabase using ArcCatalog and editing of geometry and attribute 
using ArcMap.  
Exercises  
 
1. Describe the three basic types of scanners.  
 
2. The scanned map is ready to use for analyses after scanning. Yes/No  
 
3. The scanned aerial images of aerial photographs can be used directly for 
Digital Photogrammetry Stereo compilation; Digital Elevation Modelling from 
stereo pair of scanned aerial photographs and Orthophoto Mapping. Yes/No  
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4. Calculate the optimum resolution of 1:24000 scale image to maintain the 
spatial accuracy of US National Map Accuracy Standard. 
 
5. Explain the usefulness of scanned images. 
 
 
 
This version includes commercial software such as R2V evaluation. 
 
It may be necessary to change, although the R2V is free software for 
evaluation purpose. 
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